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Part III – Minor Option in Medical Physics 2018 
Examples Sheet 

 
Any errors or comments should be addressed sent to: seb53@cam.ac.uk 
 
URLs that may be useful: 
Stanford Event Generation Simulator: http://tinyurl.com/pkg476r 
NIST: 
Tabulation of Attenuation Coefficients: http://tinyurl.com/ofowysd 
Tabulation of Relevant Biological Attenuation Coefficients: http://tinyurl.com/prvp3fb 
 
1. Radiation Interactions and Image Quality Fundamentals (Lectures 1-2) 
 
1.1  

a) Briefly describe the processes by which an X-ray photon might interact 
in tissue at diagnostic energies. 

b) How does the probability of these processes depend on the photon 
energy and the type of tissue in question?  

c) Applying conservation of energy and momentum for the relativistic 
Compton scattering, derive the relationship for E1/E0 given in lectures 
and plot a graph of the scattered angle as a function of energy. 

d) How do Compton scattered photons contribute to X-ray image noise? 
 
1.2 
Use the Stanford Event Generation Simulator (http://tinyurl.com/pkg476r) to help 
you to compare and contrast how charged particles and photons interact in 
the body. You may assume that the body is composed entirely of water. How 
deep does an electron beam of energy 100keV, 1MeV or 10MeV penetrate 
compared to a photon beam of the same energy? How many photons per 
electron will one observe behind the body at each of these energies, 
assuming a body thickness of 30cm? 
 
Hints: You will need to use the zoom and move options on the generated plots to see the 
tracks of low energy electrons. It may help to generate electrons without allowing a vertical 
spread in the y axis. 
 
1.3 
Image quality metrics are best understood using an illustrative worked 
example. Please see the end of this document for the full instructions on how 
to complete this question. 
 
2. Imaging with non-ionising radiation (Lectures 3-7) 
 
Ultrasound 
 
2.1 
Using the data in the table (next page), calculate the intensity transmission 
coefficient for the following interfaces, assuming i. normal incidence and ii. 45 
degree incidence of the ultrasound beam: 

a) Muscle/kidney. 
b) Air/muscle. 
c) Bone/muscle. 
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Discuss the implications of these values for ultrasound imaging. 
 
Tissue Z x 105  

(gcm-2s-1) 
c 
(ms-1) 

Density 
(kgm-3) 

Compressibility 
x 1011  
(cmg-1s2) 

Muscle 1.7 1590 1075 3.7 
Kidney 1.62 1560 1040 4.0 
Air 0.00043 330 1.3 70000 
Bone 7.8 4000 1908 0.3 
 
2.2 
To improve the efficiency of ultrasound transducers, we attempt to minimise 
the amount of energy reflected between the PZT crystal and the object of 
interest using impedance matching.  

a) For a layer of acoustic impedance ZM placed between the transducer 
(ZPZT) and skin (Zskin), show that the value of ZM that minimises the 
reflected energy is  

ZM = ZPZTZskin  
b) Given values of ZPZT=30x105 gcm-2s-1 and Zskin=1.7x105 gcm-2s-1, 

calculate what fraction of transducer energy is transmitted. 
c) If a transducer element has a thickness of one-half of the wavelength 

of ultrasound in the crystal (to produce resonance), show that the 
thickness of the matching layer between the transducer and the body 
should be one-quarter of the ultrasound wavelength. 

 
2.3 
Show that, in the scan plane, the beam of a single 1mm wide element of a 
3MHz linear array has a near field length of only about 0.5mm and then 
diverges between angles ± 30 degrees to the axis. How would the beam be 
modified if it were produced by an active group of 20 adjacent elements? 
 
2.4 

a) Explain the process of image formation in B-mode and Doppler.  
b) For each of these imaging modes, give two examples of common 

artifacts that are observed in the images. 
c) How can these artifacts be avoided or minimised? 
d) Which of these imaging modes has the greatest potential to do harm to 

the patient and why?  
e) How can the ultrasound operator minimise the risk of harm to the 

patient? 
 
MRI 
 
2.5 

a) Assuming that there are 6.7 x 1022 protons in a cubic centimetre of 
water, what is the magnetization contained within this volume at 3T? 
Note: M0 = μz(Nparallel-Nanti-parallel) 
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b) Explain	briefly why protons are particularly suitable for nuclear 
magnetic 
resonance imaging (MRI). Where are protons found in the body? 

c) What is a free induction decay? Why does it persist for a long time in a 
homogeneous B0 field but decay more rapidly in an inhomogeneous 
field? 

d) A tissue with T1=500 ms and T2=50 ms is initially at equilibrium when 
the following sequence of RF pulses is applied to it: A 180 degree 
pulse, a gap of 250 ms, a 90 degree pulse, a gap of 500 ms and a final 
90 degree pulse. What would be the relative size of the free induction 
signals following each 90 degree pulse? 

 
2.6 

a) Draw and annotate a gradient echo pulse sequence diagram with the 
following: TR, TE, RF pulse, Gslice, Gfrequency, Gphase and explain 
how an image is formed as a result. 

b) Why is it necessary to have an opposite polarity gradient pulse 
immediately after the slice selection gradient? Approximately what area 
should this pulse have in comparison to the slice select gradient? 

c) Water has a T1 of 2.5s and a T2 of 250ms.  Give appropriate estimates 
of TR, TE and flip angle in the gradient echo sequence to produce: 

i. A T1 weighted image 
ii. A T2

* weighted image 
iii. A proton density weighted image 

d) For each image type in part (b), explain which type of tissue would 
have the highest signal intensity. 

e) How would your answer to (b) change if this were a spin echo 
sequence? 

f) Will T1 and T2 increase or decrease if the temperature is increased?  
Justify your answer. 

 
2.7 
The figure below shows a sagittal spin echo image of the brain. Explain why 
the back of the subjects’ head appears on the left-hand side of this image. 
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2.8 
Due to magnetic shielding of the surrounding electron cloud, the hydrogen 
nuclei in fat precess approximately 3.4ppm slower than the hydrogen nuclei in 
water. In a gradient echo sequence this will result in fat and water becoming 
periodically 180° out-of-phase and then in-phase. What are the minimum TEs 
at 1.5T where fat and water are out-of-phase and then in phase. Hint: The 
Larmor frequency at 1.5T is approximately 64MHz. 
 

 
 
3. Imaging with ionising radiation (Lectures 8-12) 
 
3.1 
What is meant by the term effective dose? What levels of effective dose might 
typically received by patients undergoing a radiographic x-ray examinations of 
the head compared to a CT of the head? How might you justify such an 
exposure to the concerned parents of a child about to have an x-ray?  
 
3.2 

a) Outline the difference between stochastic and deterministic radiation 
effects. 

b) Describe how radiation protection can be applied to limit these effects. 
 
3.3 
A bremsstrahlung beam of polyenergetic photons with maximum energy Emax 
= 100 keV has an energy distribution given by: 

 

for E<Emax where C=10keV-1. The beam propagates through an aluminium 
plate for thickness 0.5 cm. 

a) Make a plot of the initial and final (after plate) distributions of the 
photons dN/dE as a function of E using the NIST tables for attenuation 
coefficients (see links to NIST tabulations at start of document). Note: 
this is most simply approached from a spreadsheet of dN/dE values. 

b) Write an expression for the average photon energy and estimate the 
value before and after the plate, as well as the fraction of the photons 
that interacted in the plate 

c) Repeat (a) and (b) for  
a. Different thicknesses of aluminium 
b. Lead and Beryllium 
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d) Comment on the use of Al, Be and Pb in diagnostic X-ray imaging in 
relation to properties you have derived. 

 
3.4 
A significant amount of natural radiation comes from the decay of Radium-
226. The decay chain involves a sequence of alpha and beta decays. The 
final steps in the decay chain are: 

210Bi→ 210Po→ 206Pb  
 
The first step is a beta decay with half-life of 5 days, while the second is an 
alpha decay with a half-life of 138 days.  

a) If at t=0 we have no 210Bi or 206Pb, but 1 mole of undecayed 210Po, 
what is the activity of the source at t=0 and t=84 days? 

b) If at t=0 there are N0 nuclei of 210Bi and zero nuclei of the other types, 
find expressions for the number of nuclei of each kind as a function of 
time. 

c) Hence find the time at which the 210Po population is maximum. 
 
 
3.5 

a) Explain how a scintillation detector works and how it can be used to 
measure both the intensity and the energy of a beam of radiation. 

b) Discuss the factors that have to be considered when selecting a 
scintillator for a particular imaging application. 

c) Describe the sequence of events that leads to a pulse of electrons at 
the anode of a photomultiplier tube if the tube is directed at a NaI 
scintillation crystal placed in a beam of gamma rays. 

 
3.6 

a) Outline the difference between direct and indirect methods of X-ray 
detection and explain how these are used in analogue (film) and digital 
X-ray imaging.  

b) What is meant by the depletion layer in a p-n diode? How does it arise 
and how can it be used to detect light? 

c) What are advantages of digital X-ray imaging in comparison to film? 
Your answer should include comments relating to the standard image 
quality metrics, such as SNR and MTF. 

 
3.7 
For the object shown below, draw the projections at angles of 0, 45, 90 and 
135 degrees then draw the sinogram produced by the object from 0 to 360 
degrees. Assume that a dark area in the object corresponds to an area of high 
signal. 
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3.8 

a) Write brief notes on back projection methods for image reconstruction 
of tomographic data 

b) Backproject the following, commenting on the image produced and 
suggest ways it could be improved. 

 
0 0 0 0 0 
0 0 0 0 0 
0 0 3 0 0 
0 0 0 2 0 
0 0 0 0 0 

 
3.9 
Describe the differences between rigid (including affine) and non-rigid 
registration techniques. Give an example case where each technique would 
be used 
 
3.10 

a) Using the rest mass of the electron, show that the energies of the two 
gamma rays produced by annihilation of an electron with a positron are 
511 keV.  

b) Explain the general principles of positron emission tomography (PET), 
referring to the source of contrast, the data collection procedure and 
the process of image formation in your answer.  

c) Making reference to attenuation corrections, explain why PET images 
often show an artificially high level of radioactivity in the lungs. 

 
 
4. Physics beyond Medical Imaging (Lectures 14-16) 
 
4.1  
Blood pressure is often used clinically to assess the function of the 
cardiovascular system. 
 

a) Why is the delivery of oxygen to tissues important? What factors 
determine oxygen delivery? Why is blood pressure a poor surrogate for 
oxygen delivery? 



Page 7 of 11 

b) A known quantity QLi (mmol) of lithium ions is injected into the venous 
system at time t0. The figure below shows the concentration X(t) of 
lithium in arterial blood as measured with a lithium sensitive electrode. 
What is the significance of the time interval t1-t0? 

 

 
 

c) Assuming that lithium is a predominantly extracellular ion, show that 
the cardiac output C is given by 

 

C = 60QLi

1− fPCV( ) X t( )dt
t1

∞

∫
 

 
 where fPCV is the packed cell fraction of whole blood. 

d) The X(t) curve shown does not appear to return to zero. Why might this 
be? Is this a problem? 

 
4.2  
The figure below shows a short segment of ECG (lead II) recording from a 
real patient. 
 

 
 
 

a) Briefly describe from where the ECG signal originates within the body 
and how it is measured. How is it used clinically? What does the term 
“lead” refer to? 
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b) Estimate the frequency response of the amplifier that would be 
required to faithfully record the ECG shown, as well as any variation in 
signal with respiration? 

c) What sources of electrical noise may occur over this frequency range 
in practice? What steps can be taken to minimize these? 

 
4.3 
Explain, with reference to ionising radiation interactions, how high energy 
radiation for use in radiotherapy is produced. Compare the dose deposition 
profile in tissue of photons and protons. Considering issues of normal tissue 
dose, why might you use protons instead of photons for radiotherapy?  
 
4.4 

a) Explain why fractionation is used in radiotherapy. 
b) Describe the need for a clinical target volume and planning target 

volume in radiotherapy. What is the difference between these volumes 
and what do they mean in a clinical context?  

c) Many members of the public would not fully understand why 
brachytherapy is used in oncology, due to the perceived danger of 
radioactivity.  Explain and justify why powerful gamma emitters such as 
Cs-137 should be used to treat patients.  You should reference the 
ALARA principle in your answer. 
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Question 1.3 Image quality worked example 
 
You will need to use the free software Fiji (Fiji Is Just ImageJ) to perform the 
calculations for this question. It can be downloaded for free from here: 
https://imagej.net/Fiji/Downloads  
 
Follow the steps below to process and evaluate the image quality in two 
example images. Submit answers to the points labeled in the list below as 
“Question” to your supervisor.  
 
Image content and spatial frequency 
1. Open the sample image Neuron File -> Open Samples -> Neuron 
2. Explore the image data profile of the different colour channels by moving 

your mouse around on the image and looking at the ‘value’ in the Fiji tool 
bar for each of the 5 channels. 

3. Open the Brightness & Contrast tool using Image -> Adjust -> 
Brightness/Contrast. Look at how the image in the different channels 
changes as you adjust the thresholds. Reset the values after exploring 

4. Separate out the stacked images into separate ones using Image -> 
Colour ->  Split channels 

5. Select a single image and look at the distribution of pixel data values in 
more detail using Analyse -> Histogram. Take the log, think about how 
this changes the visual appearance of the image. 

6. Choose the image C2 (green). Perform a fast fourier transform to 
generate the right hand image Process -> FFT -> FFT 

7.   
8. Question: What do the different parts of the FFT image correspond 

to in the original image?   
9. To answer this question, use the Edit -> Fill function to remove various 

parts (e.g. centre, edges, axes … ) of the Fourier transformed image and 
then use Process -> FFT -> Inverse FFT to look at the result. You will 
need to perform multiple forward transforms to explore this in depth. 
Make sure to use the function Image -> Rename for each forward 
transform that you make so that you can keep track of your findings. 

10. Draw profiles across the neuron using Analyse -> Plot profile and 
compare between different inverse transforms. 

11. Now try to apply a band pass filter (Process -> FFT -> Band pass filter) to 
the same image with different settings.  
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12. Question: What have you learnt about the relationship between 
spatial dimensions (x,y,z) and spatial frequency dimensions 
(kx,ky,kz)? 
 

 
Resolution and signal-to-noise ratio 
 
1. Open the microscopy image of embryos using File -> Open Samples -> 

Embryos. 
2. Use Analyse -> Set measurements to choose the metrics that you would 

like to extract from the image. Default options are: area, min/max and 
mean. Think about what values you need to extract from your regions of 
interest to calculate contrast and signal-to-noise ratio 

3. Draw regions of interest around an embryo and an equivalent sized 
region in the background, using Analyse -> Measure to extract your 
metrics. Think about why size of the region of interest is important. 

4. Question: What is the available contrast and signal-to-noise ratio in 
this image? 

5. Now repeat this process in the image Blobs. 
6. Apply in both images a blurring step Process -> Filters -> Gaussian blur.  
7. Question: What do you observe about the contrast and signal-to-

noise ratio having applied the blurring step? What does this tell you 
about the influence of spatial resolution on these parameters? 
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Additional Problems 
 
1 
What are the main design developments and technological advances in CT 
scanners that have enabled a reduction in imaging time to be achieved? 
 
2 
Describe and explain how the CT number for a tissue might be expected to 
change with kVp. 
 
3 
In a certain ultrasound beam, the last axial maximum is 0.2 m from the face of 
the circular piezoelectric transducer and is continuously excited. If the speed 
of sound is 1500 ms-1 in tissue and the frequency of ultrasound is 3 MHz, 
what is: 

a) The transducer diameter? 
b) The angle of divergence in the far field? 

 
4 
Describe the different methods of measuring blood vessel concentration and 
perfusion in tissue by ultrasound. Which deposits the largest amount of 
energy in tissue? How can the potential adverse effects in tissue be 
minimised? 
 
5 
A Doppler ultrasound transducer emits ultrasound whose wavelength is 
0.3mm. What is the frequency shift observed as the probe is angled at 45 
degrees relative to a blood vessel with a flow of 0.1 ms-1? 
 
6 
Outline the methodology for performing fMRI and diffusion weighted imaging. 
Give an example application of each method. 
 
7 
Imaging in nuclear medicine (using single photon emitters) can be performed 
using planar or tomographic geometry.  

a) For each method, give an example of the clinical use and discuss why 
it is suitable for the application. You should make reference to the 
spatial and temporal resolution, signal to noise ratio and financial 
burden in your answer. 

b) Comment on why bone scans represent the bulk of the workload for 
most Nuclear Medicine Departments. 

c) Give an example of a nuclear medicine procedure where dynamic 
scanning is required. Suggest how the same procedure could be 
conducted with an imaging modality that uses non-ionising radiation 
and what the strengths and weaknesses of this approach would be. 

 


